Not that I’m really very surprised but Outlook 2007 will not connect to Exchange 5.5. I found a note about this on the TechNet Forums:

“Microsoft continuously strives to provide a consistent and predictable end-of-life-cycle experience for all of its products.  In accordance with standard Microsoft life-cycle policies Exchange 5.5 ended extended life-cycle support on January 10, 2006.  As a result, Outlook 2007 will not support Exchange 5.5.  Because neither the Outlook or Exchange team is supporting this combination we will not discover and/or fix issues that crop up as the result of innovations in both products .  Rather than subjecting customers to potential serious issues like data loss or frequent server downtime we choose to prevent Outlook from connecting to these older and now unsupported servers.  Our research has shown that there is a relatively small set of customers who want to upgrade their desktops to the latest and greatest versions of Office and run server technology as old as Exchange 5.5.  There are clearly exceptions but they don’t seem to be the norm.”

Something to keep in mind if, like me, you need to connect to an Exchange 5.5 email server.